NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2206 — vncrecorder

MEDIUM

CVE-2020-2206 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:vncrecorder. A fix is available for org.jenkins-ci.plugins:vncrecorder — see the affected versions and patch details below.

Reflected XSS vulnerability in Jenkins VncRecorder Plugin

Also known asGHSA-fq52-6cjf-jw59
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.91%1.37%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:vncrecorder

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the checkVncServ form validation endpoint output.

This results in a reflected cross-site scripting (XSS) vulnerability.

VncRecorder Plugin 1.35 escapes the parameter value in the output.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:vncrecorderall versions1.35org.jenkins-ci.plugins:vncrecorder:1.35

Affected Products

1 product · 1 configurations
Application
vncrecorderjenkins
≤ 1.25
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:vncrecorder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:vncrecorder to 1.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2206 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the `checkVncServ` form validation endpoint output. This results in a reflected cross-site scripting (XSS) vulnerability. VncRecorder Plugin 1.35 escapes the parameter value in the output.
O3 Security · Impact-Aware SCA

Is CVE-2020-2206 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2206: vncrecorder XSS — Fixed in 1.35