NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-2179 — yaml-axis

HIGHFix: jenkinsci/yaml-axis-plugin@3468028

CVE-2020-2179 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in org.jenkins-ci.plugins:yaml-axis. A fix is available for org.jenkins-ci.plugins:yaml-axis — see the affected versions and patch details below.

RCE vulnerability in Jenkins Yaml Axis Plugin

Also known asGHSA-324h-2v7h-q3xx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.19%1.29%2.39%3.48%0.8%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:yaml-axis

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to configure a multi-configuration (Matrix) job, or control the contents of a previously configured job’s SCM repository.

Yaml Axis Plugin 0.2.1 configures its YAML parser to only instantiate safe types.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:yaml-axisall versions0.2.1org.jenkins-ci.plugins:yaml-axis:0.2.1

Affected Products

1 product · 1 configurations
Application
yaml axisjenkins
≤ 0.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:yaml-axis, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:yaml-axis to 0.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2179 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to configure a multi-configuration (Matrix) job, or control the contents of a previously configured job’s SCM repository. Yaml Axis Plugin 0.2.1 configures its YAML parser to only instantiate safe types.
O3 Security · Impact-Aware SCA

Is CVE-2020-2179 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2179: yaml-axis RCE — Fixed in 0.2.1