NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-2167 — openshift-pipeline

HIGH

CVE-2020-2167 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in com.openshift.jenkins:openshift-pipeline. A fix is available for com.openshift.jenkins:openshift-pipeline — see the affected versions and patch details below.

RCE vulnerability in Jenkins OpenShift Pipeline Plugin

Also known asGHSA-264w-xrr7-6qqg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
1.53%2.50%3.47%4.43%3.9%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.openshift.jenkins:openshift-pipeline

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to OpenShift Pipeline Plugin’s build step. OpenShift Pipeline Plugin 1.0.57 configures its YAML parser to only instantiate safe types.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.openshift.jenkins:openshift-pipelineall versions1.0.57com.openshift.jenkins:openshift-pipeline:1.0.57

Affected Products

1 product · 1 configurations
Application
openshift pipelinejenkins
≤ 1.0.56
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.openshift.jenkins:openshift-pipeline, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.openshift.jenkins:openshift-pipeline to 1.0.57 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2167 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

The jenkins-2-plugins package in OpenShift Container Platform 4 does not include the Jenkins OpenShift Pipeline Plugin.

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-0:2.204.2.1585048146-1.el7RHSA-2020:0964

Frequently Asked Questions

OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to OpenShift Pipeline Plugin’s build step. OpenShift Pipeline Plugin 1.0.57 configures its YAML parser to only instantiate safe types.
O3 Security · Impact-Aware SCA

Is CVE-2020-2167 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2167: openshift-pipeline RCE — Fixed in 1.0.57