NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2147 — mac

MEDIUMFix: jenkinsci/mac-plugin@86aebd3

CVE-2020-2147 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in fr.edf.jenkins.plugins:mac. A fix is available for fr.edf.jenkins.plugins:mac — see the affected versions and patch details below.

CSRF vulnerability in Mac Plugin

Also known asGHSA-qcfq-35v7-4fw7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.4%0.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕fr.edf.jenkins.plugins:mac

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site request forgery vulnerability in Jenkins Mac Plugin 1.1.0 and earlier allows attackers to connect to an attacker-specified SSH server using attacker-specified credentials.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenfr.edf.jenkins.plugins:macall versions1.2.0fr.edf.jenkins.plugins:mac:1.2.0

Affected Products

1 product · 1 configurations
Application
macjenkins
≤ 1.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fr.edf.jenkins.plugins:mac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fr.edf.jenkins.plugins:mac to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2147 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cross-site request forgery vulnerability in Jenkins Mac Plugin 1.1.0 and earlier allows attackers to connect to an attacker-specified SSH server using attacker-specified credentials.
O3 Security · Impact-Aware SCA

Is CVE-2020-2147 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2147: mac CSRF — Fixed in 1.2.0