NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2136 — git

MEDIUMFix: jenkinsci/git-plugin@f581998

CVE-2020-2136 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:git. A fix is available for org.jenkins-ci.plugins:git — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Jenkins Git Plugin

Also known asGHSA-6c7r-6p5m-cp82
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:git

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Git Plugin 4.2.0 and earlier does not escape the error message for the repository URL for Microsoft TFS field form validation, resulting in a stored cross-site scripting vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:gitall versions4.2.1org.jenkins-ci.plugins:git:4.2.1

Affected Products

1 product · 1 configurations
Application
gitjenkins
≤ 4.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:git, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:git to 4.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2136 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1591354111-1.el7RHSA-2020:2478
Red Hat OpenShift Container Platform 4.3jenkins-2-plugins-0:4.3.1597915133-1.el7RHSA-2020:3616
Red Hat OpenShift Container Platform 4.4jenkins-2-plugins-0:4.4.1592817009-1.el7RHSA-2020:2737
Red Hat OpenShift Container Platform 4.5openshift4/ose-aws-machine-controllers:v4.5.0-202007012112.p0RHBA-2020:2409

Frequently Asked Questions

Jenkins Git Plugin 4.2.0 and earlier does not escape the error message for the repository URL for Microsoft TFS field form validation, resulting in a stored cross-site scripting vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2020-2136 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2136: git XSS — Fixed in 4.2.1