NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-2135 — script-security

HIGHFix: jenkinsci/script-security-plugin@5b1969e

CVE-2020-2135 is a high-severity (CVSS 8.8) CWE-863 vulnerability in org.jenkins-ci.plugins:script-security. A fix is available for org.jenkins-ci.plugins:script-security — see the affected versions and patch details below.

Sandbox bypass vulnerability in Script Security Plugin

Also known asGHSA-qvhf-3567-pc4v
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.51%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:script-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Sandbox protection in Script Security Plugin 1.70 and earlier can be circumvented through:

  • Crafted constructor calls and bodies (due to an incomplete fix of SECURITY-582)
  • Crafted method calls on objects that implement GroovyInterceptable

This allows attackers able to specify and run sandboxed scripts to execute arbitrary code in the context of the Jenkins controller JVM.

Script Security Plugin 1.71 has additional restrictions and sanity checks to ensure that super constructors cannot be constructed without being intercepted by the sandbox. In addition, it also intercepts method calls on objects that implement GroovyInterceptable as calls to GroovyObject#invokeMethod(String, Object), which is on the list of dangerous signatures and should not be approved for use in the sandbox.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:script-securityall versions1.71org.jenkins-ci.plugins:script-security:1.71

Affected Products

1 product · 1 configurations
Application
script securityjenkins
≤ 1.70
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:script-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:script-security to 1.71 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2135 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1591354111-1.el7RHSA-2020:2478
Red Hat OpenShift Container Platform 4.3jenkins-2-plugins-0:4.3.1597915133-1.el7RHSA-2020:3616
Red Hat OpenShift Container Platform 4.4jenkins-2-plugins-0:4.4.1592817009-1.el7RHSA-2020:2737
Red Hat OpenShift Container Platform 4.5openshift4/ose-aws-machine-controllers:v4.5.0-202007012112.p0RHBA-2020:2409

Frequently Asked Questions

Sandbox protection in Script Security Plugin 1.70 and earlier can be circumvented through: - Crafted constructor calls and bodies (due to an incomplete fix of [SECURITY-582](https://www.jenkins.io/security/advisory/2017-08-07/#super-constructor-calls)) - Crafted method calls on objects that implement `GroovyInterceptable` This allows attackers able to specify and run sandboxed scripts to execute arbitrary code in the context of the Jenkins controller JVM. Script Security Plugin 1.71 has additional restrictions and sanity checks to ensure that super constructors cannot be constructed without
O3 Security · Impact-Aware SCA

Is CVE-2020-2135 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2135: script-security RCE — Fixed in 1.71