NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-1911 — hermes-engine

CRITICALFix: facebook/hermes@fe52854

CVE-2020-1911 is a critical-severity (CVSS 9.8) CWE-843 vulnerability in hermes-engine. A fix is available for hermes-engine — see the affected versions and patch details below.

Access of Resource Using Incompatible Type in Facebook Hermes

Also known asGHSA-f5x2-xv93-4p23
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.52%1.18%1.84%2.50%1.0%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

hermes-enginenpm
199Kdownloads / week

Description

A type confusion vulnerability when resolving properties of JavaScript objects with specially-crafted prototype chains in Facebook Hermes prior to commit fe52854cdf6725c2eaa9e125995da76e6ceb27da allows attackers to potentially execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmhermes-engineall versions0.5.2npm install hermes-engine@0.5.2

Affected Products

1 product · 1 configurations
Application
hermesfacebook
< 0.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hermes-engine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hermes-engine to 0.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-1911 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A type confusion vulnerability when resolving properties of JavaScript objects with specially-crafted prototype chains in Facebook Hermes prior to commit fe52854cdf6725c2eaa9e125995da76e6ceb27da allows attackers to potentially execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.
O3 Security · Impact-Aware SCA

Is CVE-2020-1911 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-1911: hermes-engine RCE — Fixed in 0.5.2