NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2020-15904 — bsdiff4

HIGHFix: ilanschnell/bsdiff4@49a4cee

CVE-2020-15904 is a high-severity (CVSS 7.8) Out-of-bounds Write vulnerability in bsdiff4. A fix is available for bsdiff4 — see the affected versions and patch details below.

bsdiff4 out-of-bounds write via patch file

Also known asGHSA-f8m3-jpxr-hm5xPYSEC-2020-30
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.52%1.03%1.55%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍bsdiff4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIbsdiff4all versions1.2.0pip install --upgrade 'bsdiff4==1.2.0'

Affected Products

1 product · 1 configurations
Application
bsdiff4pypi
< 1.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bsdiff4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bsdiff4 to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15904 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.
O3 Security · Impact-Aware SCA

Is CVE-2020-15904 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-15904: bsdiff4 — Fixed in 1.2.0