NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

CVE-2020-15899 — grin

HIGH

CVE-2020-15899 is a high-severity (CVSS 7.5) CWE-345 vulnerability in grin. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for grin — see the affected versions and patch details below.

Grin insufficient data validation

Also known asGHSA-p75g-gcv5-42qg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.84%1.25%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀grin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Grin 3.0.0 before 4.0.0 has insufficient validation of data related to Mimblewimble.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iogrin≥ 3.0.0&&< 4.0.04.0.0cargo update -p grin --precise 4.0.0

Affected Products

1 product · 1 configurations
Application
gringrin
≥ 3.0.0 && < 4.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grin to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15899 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Grin 3.0.0 before 4.0.0 has insufficient validation of data related to Mimblewimble.
O3 Security · Impact-Aware SCA

Is CVE-2020-15899 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2020-15899: grin — Fixed in 4.0.0