NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-15887 — softwareupdate

HIGH

CVE-2020-15887 is a high-severity (CVSS 8.8) SQL Injection vulnerability in munkireport/softwareupdate. A fix is available for munkireport/softwareupdate — see the affected versions and patch details below.

MunkiReport Software Update module is vulnerable to SQL injection

Also known asGHSA-4qgh-m9vp-48xp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.17%1.76%0.4%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘munkireport/softwareupdate

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A SQL injection vulnerability in softwareupdate_controller.php in the Software Update module before 1.6 for MunkiReport allows attackers to execute arbitrary SQL commands via the last URL parameter of the /module/softwareupdate/get_tab_data/ endpoint.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmunkireport/softwareupdateall versions1.6composer require munkireport/softwareupdate:^1.6

Affected Products

1 product · 1 configurations
Application
softwareupdatesoftwareupdate_project
< 1.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for munkireport/softwareupdate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update munkireport/softwareupdate to 1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15887 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

A SQL injection vulnerability in softwareupdate_controller.php in the Software Update module before 1.6 for MunkiReport allows attackers to execute arbitrary SQL commands via the last URL parameter of the /module/softwareupdate/get_tab_data/ endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2020-15887 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-15887: softwareupdate — Fixed in 1.6