NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧
💧 Hex
Not in CISA KEV
CRITICAL severity

CVE-2020-15150 — paginator

CRITICALFix: duffelhq/paginator@bf45e92

CVE-2020-15150 is a critical-severity (CVSS 9.8) Code Injection vulnerability in paginator. A fix is available for paginator — see the affected versions and patch details below.

Remote Code Execution in paginator

Also known asGHSA-w98m-2xqg-9cvj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
2.66%3.77%4.89%6.00%5.4%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💧paginator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.

Description

There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function.

Impact

There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version >= 1.0.0.

Patches

The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.

Credits

Thank you to Peter Stöckli.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💧Hexpaginatorall versions1.0.0mix deps.update paginator

Affected Products

1 product · 1 configurations
Application
paginatorduffel
< 1.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paginator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update paginator to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15150 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the `paginate()` function. ### Impact There is a vulnerability in Paginator which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the `paginate()` function. This will potentially affect all current users of `Paginator` prior to version >= 1.0.0. ### Patches The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an
O3 Security · Impact-Aware SCA

Is CVE-2020-15150 in your dependencies?

Find it across Hex, including transitive dependencies.

CVE-2020-15150: paginator RCE — Fixed in 1.0.0