CVE-2020-14942 — tendenci
CRITICALCVE-2020-14942 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in tendenci. A fix is available for tendenci — see the affected versions and patch details below.
Deserialization of Untrusted Data in Tendenci
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tendenciReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Tendenci 12.0.10 allows unrestricted deserialization in apps\helpdesk\views\staff.py.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tendenci | all versions | 12.0.11pip install --upgrade 'tendenci==12.0.11' |
Affected Products
tendencitendenciDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tendenci, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tendenci to 12.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-14942 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2020-14942 in your dependencies?
Find it across PyPI, including transitive dependencies.