NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-13870 — comments

MEDIUM

CVE-2020-13870 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in verbb/comments. A fix is available for verbb/comments — see the affected versions and patch details below.

Comments plugin stored Cross-site Scripting (XSS) via an asset volume name

Also known asGHSA-69ww-wv3j-mhg4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘verbb/comments

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the Comments plugin before 1.5.5 for Craft CMS. There is stored XSS via an asset volume name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistverbb/commentsall versions1.5.5composer require verbb/comments:^1.5.5

Affected Products

1 product · 1 configurations
Application
commentsverbb
< 1.5.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for verbb/comments, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update verbb/comments to 1.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13870 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in the Comments plugin before 1.5.5 for Craft CMS. There is stored XSS via an asset volume name.
O3 Security · Impact-Aware SCA

Is CVE-2020-13870 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-13870: comments XSS — Fixed in 1.5.5