NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2020-13822 — elliptic

HIGHFix: indutny/elliptic@856fe4d

CVE-2020-13822 is a high-severity (CVSS 7.7) CWE-190 vulnerability in elliptic. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for elliptic — see the affected versions and patch details below.

Signature Malleabillity in elliptic

Also known asGHSA-vh7m-p724-62c2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.15%2.31%3.46%0.2%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ellipticnpm
17.0Mdownloads / week

Description

The Elliptic package before version 6.5.3 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmellipticall versions6.5.3npm install elliptic@6.5.3

Affected Products

1 product · 1 configurations
Application
ellipticindutny
1 version
6.5.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elliptic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update elliptic to 6.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13822 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In both OpenShift Container Platform (OCP) and OpenShift ServiceMesh (OSSM), the grafana and prometheus containers don't use the vulnerable elliptic library for authentication (OpenShift OAuth is used) or traffic communications (OpenShift route is used). Therefore the impact for OCP and OSSM is Low. Red Hat Quay…

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.6openshift4/ose-grafana:v4.6.0-202010061132.p0RHSA-2020:4298
Red Hat Single Sign-On 7nodejsRHSA-2020:5533

Frequently Asked Questions

The Elliptic package before version 6.5.3 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.
O3 Security · Impact-Aware SCA

Is CVE-2020-13822 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-13822: elliptic — Fixed in 6.5.3