CVE-2020-12889 is a critical-severity (CVSS 9.8) vulnerability in misp-maltego. A fix is available for misp-maltego — see the affected versions and patch details below.
Maltego incorrectly shares a MISP connection across users in a remote-transform use case
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
misp-maltegoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
MISP MISP-maltego 1.4.4 incorrectly shares a MISP connection across users in a remote-transform use case. Version 1.4.5 contains a patch.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | misp-maltego | all versions | 1.4.5pip install --upgrade 'misp-maltego==1.4.5' |
Affected Products
misp-maltegomispDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for misp-maltego, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update misp-maltego to 1.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-12889 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-12889 in your dependencies?
Find it across PyPI, including transitive dependencies.