CVE-2020-11110 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in github.com/grafana/grafana. A fix is available for github.com/grafana/grafana — see the affected versions and patch details below.
Grafana stored XSS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/grafana/grafanaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Grafana through 6.7.1 allows stored XSS due to insufficient input protection in the originalUrl field, which allows an attacker to inject JavaScript code that will be executed after clicking on Open Original Dashboard after visiting the snapshot.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/grafana/grafana | all versions | 6.7.2go get github.com/grafana/grafana@v6.7.2 |
Affected Products
grafanagrafanae-series performance analyzernetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/grafana/grafana, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/grafana/grafana to 6.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-11110 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2020-11110
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2020-11110 -u https://target- Template
- Grafana <= 6.7.1 - Cross-Site Scripting
- Severity
- medium
- Impact
- Successful exploitation of this vulnerability could allow an attacker to execute arbitrary JavaScript code in the context of the victim's browser, leading to potential data theft or unauthorized actions.
- Remediation
- This issue can be resolved by updating Grafana to the latest version.
Template by ProjectDiscovery nuclei-templates (emadshanab), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Both OpenShift 3.11 and 4.x grafana-container's package a vulnerable version of grafana. However the grafana instance is set to read-only meaning that the potential XSS attack cannot be performed because the original url field cannot be modified. Access to the grafana panel is additionally behind OpenShift OAuth proxy…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | grafana-0:6.7.4-3.el8 | RHSA-2020:4682 |
| Red Hat OpenShift Container Platform 4.6 | openshift4/ose-grafana:v4.6.0-202010061132.p0 | RHSA-2020:4298 |
Frequently Asked Questions
Is CVE-2020-11110 in your dependencies?
Find it across Go, including transitive dependencies.