NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2020-10749 — plugins

MEDIUM

CVE-2020-10749 is a medium-severity (CVSS 6) CWE-300 vulnerability in github.com/containernetworking/plugins. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/containernetworking/plugins — see the affected versions and patch details below.

containernetworking/plugins vulnerable to MitM attacks

Also known asGHSA-fx6x-h9g4-56f8GO-2023-1915
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.84%2.62%4.41%6.19%5.2%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/containernetworking/plugins

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was found in all versions of containernetworking/plugins before version 0.8.6, that allows malicious containers in Kubernetes clusters to perform man-in-the-middle (MitM) attacks. A malicious container can exploit this flaw by sending rogue IPv6 router advertisements to the host or other containers, to redirect traffic to the malicious container.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containernetworking/pluginsall versions0.8.6go get github.com/containernetworking/plugins@v0.8.6

Affected Products

4 products · 5 configurations
OS
fedorafedoraproject
1 version
32
Application
cni network pluginslinuxfoundation
< 0.8.6
range
OS
enterprise linuxredhat
2 versions
7.08.0
Application
openshift container platformredhat
1 version
4.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containernetworking/plugins, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containernetworking/plugins to 0.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10749 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In OpenShift Container Platform 4, the default network plugin, OpenShift SDN, and OVN Kubernetes, do not forward IPv6 traffic, making this vulnerability not exploitable. The affected code from containernetworking/plugins is however still included in these plugins, hence this vulnerability is rated Low for both…

Workaround published by Red Hat
Prevent untrusted, non-privileged containers from running with CAP_NET_RAW.
Source: Red Hat security advisory for CVE-2020-10749 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extrascontainernetworking-plugins-0:0.8.3-3.el7_8RHSA-2020:2684
Red Hat Enterprise Linux 8container-tools:rhel8-8030020200923153805.2a301c24RHSA-2020:4694
Red Hat OpenShift Container Platform 4.2containernetworking-plugins-0:0.8.6-1.rhaos4.2.el7RHSA-2020:2592
Red Hat OpenShift Container Platform 4.3containernetworking-plugins-0:0.8.6-1.rhaos4.3.el7RHSA-2020:2443
Red Hat OpenShift Container Platform 4.4containernetworking-plugins-0:0.8.6-1.rhaos4.4.el7RHSA-2020:2403
Red Hat OpenShift Container Platform 4.5openshift4/ose-aws-machine-controllers:v4.5.0-202007012112.p0RHBA-2020:2409
Red Hat OpenShift Container Platform 4.5openshift4/ose-multus-cni:v4.5.0-202007012112.p0RHSA-2020:2412
Red Hat OpenShift Container Platform 4.7openshift4/ose-sdn-rhel8:v4.7.0-202102130115.p0RHSA-2020:5633

Frequently Asked Questions

A vulnerability was found in all versions of containernetworking/plugins before version 0.8.6, that allows malicious containers in Kubernetes clusters to perform man-in-the-middle (MitM) attacks. A malicious container can exploit this flaw by sending rogue IPv6 router advertisements to the host or other containers, to redirect traffic to the malicious container.
O3 Security · Impact-Aware SCA

Is CVE-2020-10749 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-10749: plugins — Fixed in 0.8.6