NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2019-9844 — simple-markdown

MEDIUMFix: Khan/simple-markdown#63

CVE-2019-9844 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in simple-markdown. A fix is available for simple-markdown — see the affected versions and patch details below.

Cross-Site Scripting in simple-markdown

Also known asGHSA-qj3f-9gmq-fwv5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.18%1.77%0.4%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

143other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
simple-markdownnpm
435Kdownloads / week

Description

Versions of simple-markdown prior to 0.4.4 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization the package may render output containing malicious JavaScript. This vulnerability can be exploited through input of links containing data or VBScript URIs and a base64-encoded payload.

Recommendation

Upgrade to version 0.4.4 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsimple-markdownall versions0.4.4npm install simple-markdown@0.4.4

Affected Products

2 products · 2 configurations
OS
fedorafedoraproject
1 version
30
Application
simple-markdownkhanacademy
< 0.4.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simple-markdown, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simple-markdown to 0.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-9844 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of `simple-markdown` prior to 0.4.4 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization the package may render output containing malicious JavaScript. This vulnerability can be exploited through input of links containing `data` or VBScript URIs and a base64-encoded payload. ## Recommendation Upgrade to version 0.4.4 or later.
O3 Security · Impact-Aware SCA

Is CVE-2019-9844 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2019-9844: simple-markdown XSS — Fixed in 0.4.4