NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-9735 — neutron

MEDIUM

CVE-2019-9735 is a medium-severity (CVSS 6.5) CWE-755 vulnerability in neutron. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for neutron — see the affected versions and patch details below.

OpenStack Neutron's unsupported dport option prevents applying security groups

Also known asGHSA-9773-3fqg-8w25PYSEC-2019-190
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.35%2.32%3.28%4.25%1.9%3.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍neutron🐍neutron🐍neutron🐍neutron

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the iptables firewall module in OpenStack Neutron before 10.0.8, 11.x before 11.0.7, 12.x before 12.0.6, and 13.x before 13.0.3. By setting a destination port in a security group rule along with a protocol that doesn't support that option (for example, VRRP), an authenticated user may block further application of security group rules for instances from any project/tenant on the compute hosts to which it's applied. (Only deployments using the iptables security group driver are affected.)

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIneutronall versions10.0.8pip install --upgrade 'neutron==10.0.8'
🐍PyPIneutron≥ 11.0.0&&< 11.0.711.0.7pip install --upgrade 'neutron==11.0.7'
🐍PyPIneutron≥ 12.0.0&&< 12.0.612.0.6pip install --upgrade 'neutron==12.0.6'
🐍PyPIneutron≥ 13.0.0&&< 13.0.313.0.3pip install --upgrade 'neutron==13.0.3'

Affected Products

3 products · 8 configurations
OS
debian linuxdebian
1 version
9.0
Application
neutronopenstack
≥ 13.0.0 && < 13.0.3
range
Application
openstackredhat
3 versions
101314
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neutron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update neutron to 10.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-9735 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)openstack-neutron-1:9.4.1-40.el7ostRHSA-2019:0916
Red Hat OpenStack Platform 13.0 (Queens)openstack-neutron-1:12.0.5-11.el7ostRHSA-2019:0935
Red Hat OpenStack Platform 14.0 (Rocky)openstack-neutron-1:13.0.3-0.20190313155649.00b63be.el7ostRHSA-2019:0879

Frequently Asked Questions

An issue was discovered in the iptables firewall module in OpenStack Neutron before 10.0.8, 11.x before 11.0.7, 12.x before 12.0.6, and 13.x before 13.0.3. By setting a destination port in a security group rule along with a protocol that doesn't support that option (for example, VRRP), an authenticated user may block further application of security group rules for instances from any project/tenant on the compute hosts to which it's applied. (Only deployments using the iptables security group driver are affected.)
O3 Security · Impact-Aware SCA

Is CVE-2019-9735 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-9735: neutron — Fixed in 10.0.8