NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-9185 — bolt

HIGHFix: bolt/bolt#7745

CVE-2019-9185 is a high-severity (CVSS 8.8) Unrestricted File Upload vulnerability in bolt/bolt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for bolt/bolt — see the affected versions and patch details below.

Bolt Unrestricted Upload of File with Dangerous Type

Also known asGHSA-gmg5-f2gm-p3h7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.53%1.41%2.29%3.16%1.0%2.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bolt/bolt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Controller/Async/FilesystemManager.php in the filemanager in Bolt before 3.6.5 allows remote attackers to execute arbitrary PHP code by renaming a previously uploaded file to have a .php extension.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbolt/boltall versions3.6.5composer require bolt/bolt:^3.6.5

Affected Products

1 product · 1 configurations
Application
boltboltcms
< 3.6.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bolt/bolt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bolt/bolt to 3.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-9185 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

Controller/Async/FilesystemManager.php in the filemanager in Bolt before 3.6.5 allows remote attackers to execute arbitrary PHP code by renaming a previously uploaded file to have a .php extension.
O3 Security · Impact-Aware SCA

Is CVE-2019-9185 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-9185: bolt — Fixed in 3.6.5