NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2019-8400 — hydra

MEDIUMFix: ory/hydra@9b5bbd4

CVE-2019-8400 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in github.com/ory/hydra. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/ory/hydra — see the affected versions and patch details below.

Hydra has Reflected XSS via error_hint parameter

Also known asGHSA-7v6r-w4r6-mhchGO-2026-4861
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.83%0.3%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/ory/hydra

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

ORY Hydra before v1.0.0-rc.3+oryOS.9 has Reflected XSS via the oauth2/fallbacks/error error_hint parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/ory/hydraall versions1.4.8go get github.com/ory/hydra@v1.4.8

Affected Products

1 product · 129 configurations
Application
hydraory
90 versions
0.10.2.00.3.00.3.10.4.00.4.10.4.20.4.30.5.00.5.10.5.20.5.3
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ory/hydra, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/ory/hydra to 1.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-8400 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

ORY Hydra before v1.0.0-rc.3+oryOS.9 has Reflected XSS via the oauth2/fallbacks/error error_hint parameter.
O3 Security · Impact-Aware SCA

Is CVE-2019-8400 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2019-8400: hydra XSS — Fixed in 1.4.8