NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-8141 — community-edition

HIGH

CVE-2019-8141 is a high-severity (CVSS 7.2) Deserialization of Untrusted Data vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento 2 Community Edition RCE Vulnerability

Also known asGHSA-9wr9-fw9v-8fgr
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.09%1.68%2.28%2.88%1.6%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with administrative privileges (system level import) can execute arbitrary code through a Phar deserialization vulnerability in the import functionality.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.1.0&&< 2.1.192.1.19composer require magento/community-edition:^2.1.19
🐘Packagistmagento/community-edition≥ 2.2.0&&< 2.2.102.2.10composer require magento/community-edition:^2.2.10
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.32.3.3composer require magento/community-edition:^2.3.3

Affected Products

1 product · 8 configurations
Application
magentomagento
≥ 2.3.0 && < 2.3.2
1 version
2.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.1.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-8141 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with administrative privileges (system level import) can execute arbitrary code through a Phar deserialization vulnerability in the import functionality.
O3 Security · Impact-Aware SCA

Is CVE-2019-8141 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-8141: community-edition RCE — Fixed in 2.1.19