CVE-2019-8140 — community-edition
MEDIUMCVE-2019-8140 is a medium-severity (CVSS 4.9) Unrestricted File Upload vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Magento Unrestricted file upload vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An unrestricted file upload vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can manipulate the Synchronization feature in the Media File Storage of the database to transform uploaded JPEG file into a PHP file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.2.0&&< 2.2.10 | 2.2.10composer require magento/community-edition:^2.2.10 |
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.3 | 2.3.3composer require magento/community-edition:^2.3.3 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-8140 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2019-8140 in your dependencies?
Find it across Packagist, including transitive dependencies.