NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-8128 — community-edition

MEDIUM

CVE-2019-8128 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento Cross-Site Scripting via store name

Also known asGHSA-mhwc-4w67-xq2c
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.06%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can exploit it by injecting malicious Javascript into the name of main website.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.2&&< 2.2.102.2.10composer require magento/community-edition:^2.2.10
🐘Packagistmagento/community-edition≥ 2.3&&< 2.3.2-p12.3.2-p1composer require magento/community-edition:^2.3.2-p1

Affected Products

1 product · 6 configurations
Application
magentomagento
≥ 2.3.0 && < 2.3.2
1 version
2.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-8128 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can exploit it by injecting malicious Javascript into the name of main website.
O3 Security · Impact-Aware SCA

Is CVE-2019-8128 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-8128: community-edition XSS — Fixed in 2.2.10