NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-7934 — community-edition

MEDIUM

CVE-2019-7934 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento 2 Community Edition XSS Vulnerability

Also known asGHSA-77mv-p94f-qcq4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.06%0.1%0.6%0.6%0.6%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to edit newsletter templates to inject malicious javascript.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.1.0&&< 2.1.182.1.18composer require magento/community-edition:^2.1.18
🐘Packagistmagento/community-edition≥ 2.2.0&&< 2.2.92.2.9composer require magento/community-edition:^2.2.9
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.22.3.2composer require magento/community-edition:^2.3.2

Affected Products

1 product · 5 configurations
Application
magentomagento
≥ 2.3.0 && < 2.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7934 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to edit newsletter templates to inject malicious javascript.
O3 Security · Impact-Aware SCA

Is CVE-2019-7934 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-7934: community-edition XSS — Fixed in 2.1.18