CVE-2019-7928 — community-edition
HIGHCVE-2019-7928 is a high-severity (CVSS 7.5) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Magento 2 Community Edition DoS vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A denial-of-service (DoS) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. By abusing insufficient brute-forcing defenses in the token exchange protocol, an unauthenticated attacker could disrupt transactions between the Magento merchant and PayPal.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.1.0&&< 2.1.18 | 2.1.18composer require magento/community-edition:^2.1.18 |
| 🐘Packagist | magento/community-edition | ≥ 2.2.0&&< 2.2.9 | 2.2.9composer require magento/community-edition:^2.2.9 |
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.2 | 2.3.2composer require magento/community-edition:^2.3.2 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7928 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2019-7928 in your dependencies?
Find it across Packagist, including transitive dependencies.