CVE-2019-7925 — community-edition
MEDIUMCVE-2019-7925 is a medium-severity (CVSS 4.9) CWE-639 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Magento Insecure Direct Object Reference (IDOR) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An insecure direct object reference (IDOR) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an administrator with limited privileges to delete the downloadable products folder.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.1&&< 2.1.18 | 2.1.18composer require magento/community-edition:^2.1.18 |
| 🐘Packagist | magento/community-edition | ≥ 2.2&&< 2.2.9 | 2.2.9composer require magento/community-edition:^2.2.9 |
| 🐘Packagist | magento/community-edition | ≥ 2.3&&< 2.3.2 | 2.3.2composer require magento/community-edition:^2.3.2 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7925 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-7925 in your dependencies?
Find it across Packagist, including transitive dependencies.