NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-3847 — moodle

MEDIUMFix: moodle/moodle@070f24d

CVE-2019-3847 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in moodle/moodle. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle XSS Vulnerability

Also known asGHSA-qrcj-6fjw-3h9h
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
2 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.37%1.17%1.97%2.77%0.9%2.2%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.6.0&&< 3.6.33.6.3composer require moodle/moodle:^3.6.3
🐘Packagistmoodle/moodle≥ 3.5.0&&< 3.5.53.5.5composer require moodle/moodle:^3.5.5
🐘Packagistmoodle/moodle≥ 3.2.0&&< 3.4.83.4.8composer require moodle/moodle:^3.4.8
🐘Packagistmoodle/moodleall versions3.1.17composer require moodle/moodle:^3.1.17

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 3.6.0 && < 3.6.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3847 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.
O3 Security · Impact-Aware SCA

Is CVE-2019-3847 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-3847: moodle — Fixed in 3.6.3