NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-3810 — moodle

MEDIUM

CVE-2019-3810 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moodle/moodle. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle XSS Vulnerability

Also known asGHSA-wm4w-8vc6-2j4h
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
4 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
13.8%probability of exploitation in next 30 days
Moderate Risk-0.06%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
6.73%9.67%12.6%15.6%8.4%13.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.6.0&&< 3.6.13.6.1composer require moodle/moodle:^3.6.1
🐘Packagistmoodle/moodle≥ 3.5.0&&< 3.5.33.5.3composer require moodle/moodle:^3.5.3
🐘Packagistmoodle/moodle≥ 3.4.0&&< 3.4.63.4.6composer require moodle/moodle:^3.4.6
🐘Packagistmoodle/moodle≥ 3.1.0&&< 3.1.153.1.15composer require moodle/moodle:^3.1.15

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 3.6.0 && ≤ 3.6.1
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-49814webappsphp

Moodle 3.6.1 - Persistent Cross-Site Scripting (XSS)

by Fariskhi Vidyan · Apr 30, 2021

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3810 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.
O3 Security · Impact-Aware SCA

Is CVE-2019-3810 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-3810: moodle — Fixed in 3.6.1