NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-25075 — gravitee-api-management

MEDIUM

CVE-2019-25075 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in io.gravitee.apim:gravitee-api-management. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.gravitee.apim:gravitee-api-management — see the affected versions and patch details below.

Path Traversal in Gravitee API Management

Also known asGHSA-xc4w-28g8-vqm5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.22%0.4%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.gravitee.apim:gravitee-api-management

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

HTML injection combined with path traversal in the Email service in Gravitee API Management before 1.25.3 allows anonymous users to read arbitrary files via a /management/users/register request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.gravitee.apim:gravitee-api-managementall versions1.25.3io.gravitee.apim:gravitee-api-management:1.25.3

Affected Products

1 product · 1 configurations
Application
api managementgravitee
< 1.25.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.gravitee.apim:gravitee-api-management, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.gravitee.apim:gravitee-api-management to 1.25.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-25075 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

HTML injection combined with path traversal in the Email service in Gravitee API Management before 1.25.3 allows anonymous users to read arbitrary files via a /management/users/register request.
O3 Security · Impact-Aware SCA

Is CVE-2019-25075 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-25075: gravitee-api — Fixed in 1.25.3