NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-19848 — cms-core

HIGH

CVE-2019-19848 is a high-severity (CVSS 7.2) Path Traversal vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

TYPO3 Directory Traversal on ZIP extraction

Also known asGHSA-77p4-wfr8-977w
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.65%1.30%1.95%0.4%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the extraction of manually uploaded ZIP archives in Extension Manager is vulnerable to directory traversal. Admin privileges are required in order to exploit this vulnerability. (In v9 LTS and later, System Maintainer privileges are also required.)

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 10.0.0&&< 10.2.210.2.2composer require typo3/cms-core:^10.2.2
🐘Packagisttypo3/cms-core≥ 8.0.0&&< 8.7.308.7.30composer require typo3/cms-core:^8.7.30
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.5.129.5.12composer require typo3/cms-core:^9.5.12
🐘Packagisttypo3/cms≥ 10.0.0&&< 10.2.210.2.2composer require typo3/cms:^10.2.2
🐘Packagisttypo3/cms≥ 8.0.0&&< 8.7.308.7.30composer require typo3/cms:^8.7.30
🐘Packagisttypo3/cms≥ 9.0.0&&< 9.5.129.5.12composer require typo3/cms:^9.5.12

Affected Products

1 product · 3 configurations
Application
typo3typo3
≥ 10.0.0 && < 10.2.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 10.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-19848 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the extraction of manually uploaded ZIP archives in Extension Manager is vulnerable to directory traversal. Admin privileges are required in order to exploit this vulnerability. (In v9 LTS and later, System Maintainer privileges are also required.)
O3 Security · Impact-Aware SCA

Is CVE-2019-19848 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-19848: cms-core Path Traversal — Fixed in 10.2.2