NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-18656 — pimcore

MEDIUMFix: pimcore/pimcore@ca036e9

CVE-2019-18656 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in pimcore/pimcore. A fix is available for pimcore/pimcore — see the affected versions and patch details below.

Pimcore XSS Vulnerability

Also known asGHSA-65p8-5423-fw3x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.0%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘pimcore/pimcore

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Pimcore 6prior to 6.3.0 has XSS in the translations grid because bundles/AdminBundle/Resources/public/js/pimcore/settings/translations.js mishandles certain HTML elements.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistpimcore/pimcoreall versions6.3.0composer require pimcore/pimcore:^6.3.0

Affected Products

1 product · 1 configurations
Application
pimcorepimcore
1 version
6.2.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pimcore/pimcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pimcore/pimcore to 6.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-18656 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Pimcore 6prior to 6.3.0 has XSS in the translations grid because `bundles/AdminBundle/Resources/public/js/pimcore/settings/translations.js` mishandles certain HTML elements.
O3 Security · Impact-Aware SCA

Is CVE-2019-18656 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-18656: pimcore XSS — Fixed in 6.3.0