CVE-2019-17268 — omniauth-weibo-oauth2
CRITICALCVE-2019-17268 is a critical-severity (CVSS 9.8) Code Injection vulnerability in omniauth-weibo-oauth2. A fix is available for omniauth-weibo-oauth2 — see the affected versions and patch details below.
omniauth-weibo-oauth2 included a code-execution backdoor inserted by a third party
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
omniauth-weibo-oauth2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The omniauth-weibo-oauth2 gem 0.4.6 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Versions through 0.4.5, and 0.5.1 and later, are unaffected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | omniauth-weibo-oauth2 | ≥ 0.4.6&&< 0.5.1 | 0.5.1bundle update omniauth-weibo-oauth2 --conservative |
Affected Products
omniauth-weibo-oauth2omniauth-weibo-oauth2_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omniauth-weibo-oauth2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update omniauth-weibo-oauth2 to 0.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17268 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2019-17268 in your dependencies?
Find it across RubyGems, including transitive dependencies.