CVE-2019-17110 is a medium-severity (CVSS 6.5) vulnerability in github.com/kubernetes/kube-state-metrics. A fix is available for github.com/kubernetes/kube-state-metrics — see the affected versions and patch details below.
Duplicate Advisory: k8s.io/kube-state-metrics Exposure of Sensitive Information
Real-World Exposure
github.com/kubernetes/kube-state-metrics🐹k8s.io/kube-state-metricsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A security issue was discovered in the kube-state-metrics versions v1.7.0 and v1.7.1. An experimental feature was added to the v1.7.0 release that enabled annotations to be exposed as metrics. By default, the kube-state-metrics metrics only expose metadata about Secrets. However, a combination of the default kubectl behavior and this new feature can cause the entire secret content to end up in metric labels thus inadvertently exposing the secret content in metrics. This feature has been reverted and released as the v1.7.2 release. If you are running the v1.7.0 or v1.7.1 release, please upgrade to the v1.7.2 release as soon as possible.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kubernetes/kube-state-metrics | ≥ 1.7.0&&< 1.7.2 | 1.7.2go get github.com/kubernetes/kube-state-metrics@v1.7.2 |
| 🐹Go | k8s.io/kube-state-metrics | ≥ 1.7.0&&< 1.7.2 | 1.7.2go get k8s.io/kube-state-metrics@v1.7.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubernetes/kube-state-metrics, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kubernetes/kube-state-metrics to 1.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17110 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-17110 in your dependencies?
Find it across Go, including transitive dependencies.