CVE-2019-16699 — sr-freecap
CRITICALCVE-2019-16699 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in sjbr/sr-freecap. A fix is available for sjbr/sr-freecap — see the affected versions and patch details below.
sr_freecap for Typo3 RCE Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sjbr/sr-freecap🐘sjbr/sr-freecapReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The sr_freecap (aka freeCap CAPTCHA) extension 2.4.5 and below and 2.5.2 and below for TYPO3 fails to sanitize user input, which allows execution of arbitrary Extbase actions, resulting in Remote Code Execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | sjbr/sr-freecap | ≥ 2.5.0&&< 2.5.3 | 2.5.3composer require sjbr/sr-freecap:^2.5.3 |
| 🐘Packagist | sjbr/sr-freecap | all versions | 2.4.6composer require sjbr/sr-freecap:^2.4.6 |
Affected Products
sr freecapsr_freecap_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sjbr/sr-freecap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sjbr/sr-freecap to 2.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16699 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-16699 in your dependencies?
Find it across Packagist, including transitive dependencies.