NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-16564 — pipeline-aggregator-view

MEDIUMFix: jenkinsci/pipeline-aggregator-view-plugin@acb0eee

CVE-2019-16564 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.paul8620.jenkins.plugins:pipeline-aggregator-view. A fix is available for com.paul8620.jenkins.plugins:pipeline-aggregator-view — see the affected versions and patch details below.

Jenkins Pipeline Aggregator View Plugin stored XSS vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.paul8620.jenkins.plugins:pipeline-aggregator-view

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Pipeline Aggregator View Plugin 1.8 and earlier does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.paul8620.jenkins.plugins:pipeline-aggregator-viewall versions1.9com.paul8620.jenkins.plugins:pipeline-aggregator-view:1.9

Affected Products

1 product · 1 configurations
Application
pipeline aggregator viewjenkins
≤ 1.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.paul8620.jenkins.plugins:pipeline-aggregator-view, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.paul8620.jenkins.plugins:pipeline-aggregator-view to 1.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16564 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Jenkins Pipeline Aggregator View Plugin 1.8 and earlier does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.
O3 Security · Impact-Aware SCA

Is CVE-2019-16564 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-16564: pipeline-aggregator XSS — Fixed in 1.9