NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-15795 — python-apt

MEDIUM

CVE-2019-15795 is a medium-severity (CVSS 4.7) Broken Cryptographic Algorithm vulnerability in python-apt. A fix is available for python-apt — see the affected versions and patch details below.

python-apt Flawed Package Integrity Check

Also known asGHSA-rp8m-h266-53jh
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.32%0.63%0.95%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐍python-apt🐍python-apt🐍python-apt🐍python-apt🐍python-apt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

python-apt only checks the MD5 sums of downloaded files in Version.fetch_binary() and Version.fetch_source() of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-aptall versions0.8.3ubuntu7.5pip install --upgrade 'python-apt==0.8.3ubuntu7.5'
🐍PyPIpython-apt≥ 0.9.0&&< 0.9.3.5ubuntu30.9.3.5ubuntu3pip install --upgrade 'python-apt==0.9.3.5ubuntu3'
🐍PyPIpython-apt≥ 1.0.0&&< 1.1.01.1.0pip install --upgrade 'python-apt==1.1.0'
🐍PyPIpython-apt≥ 1.2.0&&< 1.6.5ubuntu0.11.6.5ubuntu0.1pip install --upgrade 'python-apt==1.6.5ubuntu0.1'
🐍PyPIpython-apt≥ 1.7.0&&< 1.9.0ubuntu1.21.9.0ubuntu1.2pip install --upgrade 'python-apt==1.9.0ubuntu1.2'

Affected Products

2 products · 68 configurations
Application
python-aptdebian
1 version
1.8.4
Application
python-aptubuntu
26 versions
0.8.00.8.10.8.30.8.9.10.9.00.9.10.9.3.10.9.3.20.9.3.30.9.3.40.9.3.51.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-apt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-apt to 0.8.3ubuntu7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15795 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
O3 Security · Impact-Aware SCA

Is CVE-2019-15795 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-15795: python-apt — Fix Available