NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
CRITICAL severity

CVE-2019-15554 — smallvec

CRITICAL

CVE-2019-15554 is a critical-severity (CVSS 9.8) Out-of-bounds Write vulnerability in smallvec. A fix is available for smallvec — see the affected versions and patch details below.

Memory corruption in smallvec

Also known asGHSA-69gw-hgj3-45m7RUSTSEC-2019-0012
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.89%1.77%2.66%0.4%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀smallvec

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Attempting to call grow on a spilled SmallVec with a value less than the current capacity causes corruption of memory allocator data structures. An attacker that controls the value passed to grow may exploit this flaw to obtain memory contents or gain remote code execution.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iosmallvec≥ 0.6.3&&< 0.6.100.6.10cargo update -p smallvec --precise 0.6.10

Affected Products

1 product · 1 configurations
Application
smallvecservo
≥ 0.6.3 && < 0.6.10
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for smallvec, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update smallvec to 0.6.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15554 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

Attempting to call grow on a spilled SmallVec with a value less than the current capacity causes corruption of memory allocator data structures. An attacker that controls the value passed to grow may exploit this flaw to obtain memory contents or gain remote code execution.
O3 Security · Impact-Aware SCA

Is CVE-2019-15554 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2019-15554: smallvec RCE — Fixed in 0.6.10