NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-15489 — laracom

MEDIUMFix: Laracommerce/laracom#211

CVE-2019-15489 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in jsdecena/laracom. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for jsdecena/laracom — see the affected versions and patch details below.

laracom Cross-site Scripting

Also known asGHSA-qc2p-6qrf-25j2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.2%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘jsdecena/laracom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

laracom (aka Laravel FREE E-Commerce Software) 1.4.11 has a Cross-site Scripting vulnerability via search query.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistjsdecena/laracom≥ 1.4.11&&< 1.5.01.5.0composer require jsdecena/laracom:^1.5.0

Affected Products

1 product · 1 configurations
Application
laracomlaracom
1 version
1.4.11
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsdecena/laracom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jsdecena/laracom to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15489 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

laracom (aka Laravel FREE E-Commerce Software) 1.4.11 has a Cross-site Scripting vulnerability via search query.
O3 Security · Impact-Aware SCA

Is CVE-2019-15489 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-15489: laracom XSS — Fixed in 1.5.0