CVE-2019-14837 is a critical-severity (CVSS 9.1) CWE-547 vulnerability in org.keycloak:keycloak-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.keycloak:keycloak-core — see the affected versions and patch details below.
keycloak vulnerable to unauthorized login via mail server setup
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.keycloak:keycloak-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in keycloack before version 8.0.0. The owner of 'placeholder.org' domain can setup mail server on this domain and knowing only name of a client can reset password and then log in. For example, for client name 'test' the email address will be '[email protected]'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.keycloak:keycloak-core | all versions | 8.0.0org.keycloak:keycloak-core:8.0.0 |
Affected Products
keycloakredhatsingle sign-onredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.keycloak:keycloak-core to 8.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14837 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
It is not a very straight forward workaround but it is possible to mitigate this by manually editing the default Email ID ([email protected]) to some valid email ID ([email protected]) in the USER_ENTITY table in the RHSSO database used.Source: Red Hat security advisory for CVE-2019-14837 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Single Sign-On 7.3 | see advisory | RHSA-2019:4045 |
| Red Hat Single Sign-On 7.3 for RHEL 6 | rh-sso7-keycloak-0:4.8.15-1.Final_redhat_00001.1.el6sso | RHSA-2019:4040 |
| Red Hat Single Sign-On 7.3 for RHEL 7 | rh-sso7-keycloak-0:4.8.15-1.Final_redhat_00001.1.el7sso | RHSA-2019:4041 |
| Red Hat Single Sign-On 7.3 for RHEL 8 | rh-sso7-keycloak-0:4.8.15-1.Final_redhat_00001.1.el8sso | RHSA-2019:4042 |
Frequently Asked Questions
Is CVE-2019-14837 in your dependencies?
Find it across Maven, including transitive dependencies.