CVE-2019-12747 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 Vulnerable to Insecure Deserialization
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3 8.x through 8.7.26 and 9.x through 9.5.7 allows Deserialization of Untrusted Data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.27 | 8.7.27composer require typo3/cms-core:^8.7.27 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.8 | 9.5.8composer require typo3/cms-core:^9.5.8 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.27 | 8.7.27composer require typo3/cms:^8.7.27 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.5.8 | 9.5.8composer require typo3/cms:^9.5.8 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12747 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2019-12747 in your dependencies?
Find it across Packagist, including transitive dependencies.