NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-12186 — grid

MEDIUM

CVE-2019-12186 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in sylius/grid. A fix is available for sylius/grid — see the affected versions and patch details below.

XSS injection in the Grid component of Sylius

Also known asGHSA-rc5r-697f-28x6
Published
Updated
Affected
14 pkgs
Patched
14 / 14
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

14 pkgs affected
🐘sylius/grid🐘sylius/grid🐘sylius/grid🐘sylius/grid🐘sylius/grid🐘sylius/grid-bundle🐘sylius/grid-bundle🐘sylius/grid-bundle+6 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Sylius products. Missing input sanitization in sylius/sylius 1.0.x through 1.0.18, 1.1.x through 1.1.17, 1.2.x through 1.2.16, 1.3.x through 1.3.11, and 1.4.x through 1.4.3 and sylius/grid 1.0.x through 1.0.18, 1.1.x through 1.1.18, 1.2.x through 1.2.17, 1.3.x through 1.3.12, 1.4.x through 1.4.4, and 1.5.0 allows an attacker (an admin in the sylius/sylius case) to perform XSS by injecting malicious code into a field displayed in a grid with the "string" field type. The contents are an object, with malicious code returned by the __toString() method of that object.

Affected Packages

14 total 14 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsylius/grid≥ 1.0.0&&< 1.1.191.1.19composer require sylius/grid:^1.1.19
🐘Packagistsylius/grid≥ 1.2.0&&< 1.2.181.2.18composer require sylius/grid:^1.2.18
🐘Packagistsylius/grid≥ 1.3.0&&< 1.3.131.3.13composer require sylius/grid:^1.3.13
🐘Packagistsylius/grid≥ 1.4.0&&< 1.4.51.4.5composer require sylius/grid:^1.4.5
🐘Packagistsylius/grid≥ 1.5.0&&< 1.5.11.5.1composer require sylius/grid:^1.5.1
🐘Packagistsylius/grid-bundle≥ 1.0.0&&< 1.1.191.1.19composer require sylius/grid-bundle:^1.1.19

Affected Products

2 products · 11 configurations
Application
gridsylius
≥ 1.4.0 && ≤ 1.4.4
1 version
1.5.0
Application
syliussylius
≥ 1.4.0 && ≤ 1.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sylius/grid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sylius/grid to 1.1.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12186 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in Sylius products. Missing input sanitization in sylius/sylius 1.0.x through 1.0.18, 1.1.x through 1.1.17, 1.2.x through 1.2.16, 1.3.x through 1.3.11, and 1.4.x through 1.4.3 and sylius/grid 1.0.x through 1.0.18, 1.1.x through 1.1.18, 1.2.x through 1.2.17, 1.3.x through 1.3.12, 1.4.x through 1.4.4, and 1.5.0 allows an attacker (an admin in the sylius/sylius case) to perform XSS by injecting malicious code into a field displayed in a grid with the "string" field type. The contents are an object, with malicious code returned by the __toString() method of that object.
O3 Security · Impact-Aware SCA

Is CVE-2019-12186 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12186: grid — Fixed in 1.1.19