CVE-2019-12149 — restfulserver
CRITICALCVE-2019-12149 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in silverstripe/restfulserver. A fix is available for silverstripe/restfulserver — see the affected versions and patch details below.
silverstripe restfulserver and registry modules SQL injection vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/restfulserver🐘silverstripe/registry🐘silverstripe/registry🐘silverstripe/restfulserver🐘silverstripe/restfulserverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverstripe/registry module 2.1.x before 2.1.1 and 2.2.x before 2.2.1 allows attackers to execute arbitrary SQL commands.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/restfulserver | ≥ 2.1.0&&< 2.1.2 | 2.1.2composer require silverstripe/restfulserver:^2.1.2 |
| 🐘Packagist | silverstripe/registry | ≥ 2.1.0&&< 2.1.1 | 2.1.1composer require silverstripe/registry:^2.1.1 |
| 🐘Packagist | silverstripe/registry | ≥ 2.2.0&&< 2.2.1 | 2.2.1composer require silverstripe/registry:^2.2.1 |
| 🐘Packagist | silverstripe/restfulserver | ≥ 1.0.0&&< 1.0.9 | 1.0.9composer require silverstripe/restfulserver:^1.0.9 |
| 🐘Packagist | silverstripe/restfulserver | ≥ 2.0.0&&< 2.0.4 | 2.0.4composer require silverstripe/restfulserver:^2.0.4 |
Affected Products
registrysilverstriperestfulserversilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/restfulserver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/restfulserver to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12149 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2019-12149 in your dependencies?
Find it across Packagist, including transitive dependencies.