NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2019-11830 — phar-stream-wrapper

CRITICAL

CVE-2019-11830 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in typo3/phar-stream-wrapper. A fix is available for typo3/phar-stream-wrapper — see the affected versions and patch details below.

PharStreamWrapper for Typo3 unsafe deserialization vulnerability

Also known asGHSA-3hxw-g85p-qgxm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
1.90%2.33%2.75%3.17%2.5%2.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘typo3/phar-stream-wrapper🐘typo3/phar-stream-wrapper

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

PharMetaDataInterceptor in the PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 mishandles Phar stub parsing, which allows attackers to bypass a deserialization protection mechanism.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/phar-stream-wrapper≥ 2.0.0&&< 2.1.12.1.1composer require typo3/phar-stream-wrapper:^2.1.1
🐘Packagisttypo3/phar-stream-wrapper≥ 3.0.0&&< 3.1.13.1.1composer require typo3/phar-stream-wrapper:^3.1.1

Affected Products

1 product · 2 configurations
Application
pharstreamwrappertypo3
≥ 3.0.0 && < 3.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/phar-stream-wrapper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/phar-stream-wrapper to 2.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-11830 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

PharMetaDataInterceptor in the PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 mishandles Phar stub parsing, which allows attackers to bypass a deserialization protection mechanism.
O3 Security · Impact-Aware SCA

Is CVE-2019-11830 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-11830: phar-stream-wrapper — Fixed in 2.1.1