NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2019-11254 — gopkg.in/yaml.v2

MEDIUMFix: go-yaml/yaml#555

CVE-2019-11254 is a medium-severity (CVSS 6.5) CWE-1050 vulnerability in gopkg.in/yaml.v2. A fix is available for gopkg.in/yaml.v2 — see the affected versions and patch details below.

Excessive Platform Resource Consumption within a Loop in Kubernetes

Also known asGHSA-wxc4-f4m6-wwqvGO-2020-0036
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.36%2.71%4.07%0.1%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹gopkg.in/yaml.v2🐹github.com/go-yaml/yaml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogopkg.in/yaml.v2all versions2.2.8go get gopkg.in/yaml.v2@v2.2.8
🐹Gogithub.com/go-yaml/yamlall versionsNo fix

Affected Products

1 product · 3 configurations
Application
kuberneteskubernetes
≥ 1.17.0 && < 1.17.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gopkg.in/yaml.v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update gopkg.in/yaml.v2 to 2.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-11254 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The upstream Kubernetes fix for this vulnerability is to update the version of the Go dependency, gopkg.in/yaml.v2. This issue affects OpenShift Container Platform components that use versions before 2.2.8 of gopkg.in/yaml.v2 and accept YAML payloads.

Workaround published by Red Hat
Prevent unauthenticated or unauthorized access to the API server
Source: Red Hat security advisory for CVE-2019-11254 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11atomic-openshift-0:3.11.232-1.git.0.a5bc32f.el7RHSA-2020:2479
Red Hat OpenShift Container Platform 4.3openshift4/ose-openshift-apiserver-rhel7:v4.3.9-202003230345RHSA-2020:0933
Red Hat OpenShift Container Platform 4.5openshift4/ose-hyperkube:v4.5.0-202007100518.p0RHSA-2020:2412
Red Hat OpenShift Container Platform 4.5openshift-0:4.5.0-202007012112.p0.git.0.582d7fc.el7RHSA-2020:2413

Frequently Asked Questions

The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.
O3 Security · Impact-Aware SCA

Is CVE-2019-11254 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2019-11254: gopkg.in/yaml.v2 — Fixed in 2.2.8