NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2019-11068 — nokogiri

CRITICALFix: sparklemotion/nokogiri#1898

CVE-2019-11068 is a critical-severity (CVSS 9.8) vulnerability in nokogiri. A fix is available for nokogiri — see the affected versions and patch details below.

Nokogiri vulnerable to libxslt protection mechanism bypass

Also known asGHSA-qxcg-xjjg-66mj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2019-11068.

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.15%4.31%6.46%1.1%5.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎nokogiri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

A dependency of Nokogiri, libxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsnokogiriall versions1.10.3bundle update nokogiri --conservative

Affected Products

22 products · 31 configurations
OS
ubuntu linuxcanonical
5 versions
12.0414.0416.0418.0418.10
OS
debian linuxdebian
1 version
8.0
OS
fedorafedoraproject
2 versions
2930
Application
active iq unified managernetapp
all
Application
cloud backupnetapp
all
Application
e-series santricity management plug-insnetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nokogiri to 1.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-11068 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat OpenStack will consume fixes from the base Red Hat Enterprise Linux Operating System. Therefore the package provided by Red Hat OpenStack has been marked as will not fix.

Workaround published by Red Hat
This flaw only applies to applications compiled against libxml2 which use xsltCheckRead and xsltCheckWrite functions and/or allow users to load arbitrary URLs to be parsed via libxml2. In all other cases, applications are not vulnerable.
Source: Red Hat security advisory for CVE-2019-11068 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 7libxslt-0:1.1.28-6.el7RHSA-2020:4005
Red Hat Enterprise Linux 8libxslt-0:1.1.32-5.el8RHSA-2020:4464

Frequently Asked Questions

A dependency of Nokogiri, libxslt through 1.1.33 allows bypass of a protection mechanism because callers of `xsltCheckRead` and `xsltCheckWrite` permit access even upon receiving a `-1` error code. `xsltCheckRead` can return `-1` for a crafted URL that is not actually invalid and is subsequently loaded.
O3 Security · Impact-Aware SCA

Is CVE-2019-11068 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2019-11068: nokogiri — Fixed in 1.10.3