NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2019-10791 — promise-probe

CRITICALFix: dottgonzo/node-promise-probe@0d9affb

CVE-2019-10791 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in promise-probe. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for promise-probe — see the affected versions and patch details below.

promise-probe OS command injection vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
1.47%2.26%3.05%3.84%3.3%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
promise-probenpm
49downloads / week

Description

promise-probe before 0.10.0 allows remote attackers to perform a command injection attack. The file, outputFile and options functions can be controlled by users without any sanitization.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpromise-probeall versions0.1.10npm install promise-probe@0.1.10

Affected Products

1 product · 1 configurations
Application
promise-probepromise-probe_project
< 0.10.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for promise-probe, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update promise-probe to 0.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10791 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

promise-probe before 0.10.0 allows remote attackers to perform a command injection attack. The `file`, `outputFile` and `options` functions can be controlled by users without any sanitization.
O3 Security · Impact-Aware SCA

Is CVE-2019-10791 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2019-10791: promise-probe — Fixed in 0.1.10