NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-10463 — dynatrace-dashboard

MEDIUMFix: jenkinsci/dynatrace-plugin@b6e5570

CVE-2019-10463 is a medium-severity (CVSS 6.5) Incorrect Default Permissions vulnerability in org.jenkins-ci.plugins:dynatrace-dashboard. A fix is available for org.jenkins-ci.plugins:dynatrace-dashboard — see the affected versions and patch details below.

Jenkins Dynatrace Plugin contains Incorrect Default Permissions

Also known asGHSA-cqjv-whwg-wh47
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.0%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:dynatrace-dashboard

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A missing permission check in Jenkins Dynatrace Application Monitoring Plugin allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials. This issue was patched in version 2.1.5, however, please

##NOTE: This plugin is marked as DEPRECATED

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:dynatrace-dashboardall versions2.1.5org.jenkins-ci.plugins:dynatrace-dashboard:2.1.5

Affected Products

1 product · 1 configurations
Application
dynatrace application monitoringjenkins
≤ 2.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:dynatrace-dashboard, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:dynatrace-dashboard to 2.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10463 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

A missing permission check in Jenkins Dynatrace Application Monitoring Plugin allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials. This issue was patched in version 2.1.5, however, please ##NOTE: This plugin is marked as DEPRECATED
O3 Security · Impact-Aware SCA

Is CVE-2019-10463 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10463: dynatrace-dashboard — Fixed in 2.1.5