CVE-2019-10432 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:htmlpublisher. A fix is available for org.jenkins-ci.plugins:htmlpublisher — see the affected versions and patch details below.
Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:htmlpublisherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins HTML Publisher Plugin prior to version 1.21 did not escape the project and build display names in the HTML report frame, resulting in a cross-site scripting vulnerability exploitable by users able to change those. This issue has been patched in version 1.21
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:htmlpublisher | all versions | 1.21org.jenkins-ci.plugins:htmlpublisher:1.21 |
Affected Products
html publisherjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:htmlpublisher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:htmlpublisher to 1.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10432 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | jenkins-2-plugins-0:3.11.1575261255-1.el7 | RHSA-2019:4055 |
| Red Hat OpenShift Container Platform 4.1 | jenkins-2-plugins-0:4.1.1574872364-1.el7 | RHSA-2019:4089 |
| Red Hat OpenShift Container Platform 4.2 | jenkins-2-plugins-0:4.2.1574873592-1.el7 | RHSA-2019:4097 |
Frequently Asked Questions
Is CVE-2019-10432 in your dependencies?
Find it across Maven, including transitive dependencies.