NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-10413 — datatheorem-mobile-app-se…

MEDIUM

CVE-2019-10413 is a medium-severity (CVSS 4.3) CWE-522 vulnerability in com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security. A fix is available for com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security — see the affected versions and patch details below.

Jenkins Data Theorem Mobile Security: CI/CD Plugin has Insufficiently Protected Credentials

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.50%0.0%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Data Theorem Mobile Security: CI/CD Plugin stored a proxy password unencrypted in job config.xml files on the Jenkins controller. This password could be viewed by users with Extended Read permission, or access to the Jenkins controller file system.

Data Theorem Mobile Security: CI/CD Plugin now stores the proxy password encrypted. Existing jobs need to have their configuration saved for existing plain text proxy passwords to be overwritten.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-securityall versions1.4.0com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security:1.4.0

Affected Products

1 product · 1 configurations
Application
data theorem mobile app securityjenkins
≤ 1.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10413 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Data Theorem Mobile Security: CI/CD Plugin stored a proxy password unencrypted in job `config.xml` files on the Jenkins controller. This password could be viewed by users with Extended Read permission, or access to the Jenkins controller file system. Data Theorem Mobile Security: CI/CD Plugin now stores the proxy password encrypted. Existing jobs need to have their configuration saved for existing plain text proxy passwords to be overwritten.
O3 Security · Impact-Aware SCA

Is CVE-2019-10413 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10413: datatheorem-mobile-app — Fixed in 1.4.0